Math Is Fun Forum
  Discussion about math, puzzles, games and fun.   Useful symbols: √ ∞ ≠ ≤ ≥ ≈ ⇒ ∈ Δ θ ∴ ∑ ∫ π -

Login

Username

Password

Not registered yet?

Post a reply

Go back

Write your message and submit
:) :| :( :D :o ;) :/ :P :lol: :mad: :rolleyes: :cool: | :dizzy :eek :kiss :roflol :rolleyes :shame :down :up :touched :sleep :wave :swear :tongue :what :faint :dunno
Options

Go back

Topic review (newest first)

bobbym
2009-05-16 18:28:46

It is ugly. I wouldn't use m_Data,  a week later I wouldn't remember what it meant. Unless my proggie is heavily commented, I have no chance of understanding it later.

MathsIsFun
2009-05-16 08:17:23

For me "m_Data" looks ugly, just personal preference I suppose.

LorraineBR
2009-05-16 00:18:41

my lecturer always says give it a name that means something because it will be easier to understand when reading over, in functions the first letter in the word should be in lower case but after that to have them startin with an upper case letter e.g getLengthOfArray(). he also believes that member data should start with m_ eg m_Data

Chewy
2008-10-15 21:00:01

I could see how that could happen.

MathsIsFun
2008-10-15 15:28:35

That's right, I am not being specific as to language (but we should be aware that many languages are case sensitive).

Ricky wrote:

I am opposed most of the time to call things "myWeight" for the class variables.  paramWeight seems to be too lengthy for the "???".

I have used newWeight and also TheWeight in cases like that ... it is somewhat annoying I agree.

Chewy wrote:

dim intBeans
dim intPots   etc...

I personally do not like putting the type in the name (like intBeans or charID) because if you need to change the type you then have to do variable renaming, and possibly miss one.

Ricky
2008-10-15 13:45:23

Naming conventions are almost universal.  Just about all programming languages allow variables with AZaz09_, and can't start with a number.

Chewy
2008-10-15 13:06:39

As I look at Ricky's example, it looks like you two are talking about either C++ or Java with the { 's.   I am not sure what naming conventions you should use, MathsIsFun, in regard to either of those languages. I am teaching myself some Java, and I like it so far.

Chewy
2008-10-15 13:01:06

Question:

Is this Visual Basic ? Looks like it to me, correct me if I am wrong. My instructor advised our class to use the most descriptive naming convention, while keeping it brief.

Like :

dim intBeans
dim intPots   etc... 

*Note: ("dim" in this example is the dimension (< I think it stands for dimension) command, creating variables Beans and Pots, for anyone reading this that isn't necessarily familiar with Visual Basic)

He said that using CamelCase was fine, but he preferred something short and sweet, so instead of:

dim int dayCountYesterday

he would suggest for clarity

dim int countYest

or something really short and sweet for programmers that may look over the code after the program's creation, just in case the programmer that created the code wasn't doing the revising personally.

So to shorten this up, I think that using what makes sense at first glance matters more than being strict with naming conventions. Conventions should be considered, but ultimately you could try my instructors idea, MathsIsFun. My instructor by the way used to work for Google. So I guess that he must have learned a few good ideas while working there.

Ricky
2008-10-15 11:39:20

Here is one I could never find a good solution for:

Parameter names (i.e. variable names that you pass to the function) in a modifier.  For example:

class DoesNothing {
public:
  DoesNothing();
  void Weight(int ???);
private:
  int weight;
};

I am opposed most of the time to call things "myWeight" for the class variables.  paramWeight seems to be too lengthy for the "???".

MathsIsFun
2008-10-15 10:29:03

I am trying to make my life easier by sticking to some Naming Conventions:

* avoid using "_"
* variables: use lowerCamelCase
* functions: use lowerCamelCase, with first word being a verb (like getThing(), or clearDrawing())
* classes: use UpperCamelCase
* arrays: use plural (dayNames, tableCells)
* file names: always lower case

I would also like to have some way of choosing which way around I put together variable names:

* should I use xStt or sttX ?
* how about dayCount, dayNum, currentDay, lastDay ... shouldn't "day" always be first or last?

Board footer

Powered by FluxBB